Dringend! Hilfe ! nach Update auf 3.17



  • HILFE! Nach Update von Version 3.15 auf 3.17 kann ich mich (bin Admin) nicht mehr Anmelden.
    "Benutzername oder Passwort nicht korrekt"
    Auch mit anderem Benutzername/Passwort funktioniert es nicht mehr !
    Brauche dringend Hilfe



  • Geht das Anmelden mit deiner Email?
    Ansonsten per Mail neues Kennwort anfordern?


  • ChurchTools Mitarbeiter

    Ab 3.17 ist nur noch ein Login über SSL möglich. Greifst Du per https darauf zu?
    Wenn Ihr kein SSL unterstützt kannst Du in die Config eintragen: https_only=false
    Dann geht es wieder.
    Siehe auch unseren Post unter Ankündigung.



  • @jmrauen Danke für die Info.
    Fällt nicht wirklich auf beimChangelog, auch wenn Fett dargestellt.
    Ich denke, so etwas entscheidendes sollte besonderns Kommuniziert werden. (so als Tipp fürs naächste mal :-) )
    Nun aber zum Technischen.
    Bin zwar Admin, aber kein Fachmann in Sachen Datenbanken im Internet.
    Wie und wo muss ich schauen, ob ich SSL habe und was ich umstellen muss, bzw. Wo finde ich die churchtools.config ?



  • @jmrauen : Also SSL ist aktiviert (siehe Bild)
    Anmelden geht trotzdem nicht. und nu?
    0_1483735949968_SSL.GIF



  • @Webmaster-EFM
    Greifst du dann über https zu?

    Ist dein Benutzername die Mail oder ein selbst vergebener?

    Hattest du evtl Sonderzeichen im Benutzernamen?



  • @MaxStro Guten Morgen. Was bedeutet; Über SSL zugreifen?
    Ich rufe die Seite über: http://churchtools.efm-mutterstadt.de
    auf
    https://churchtools.efm-mutterstadt.de
    Funktioniert nicht.
    Habe kein Sonderzeichen im Benutzernamen



  • @Webmaster-EFM Ja, das ist das Problem; du musst über https://... zugreifen. Dafür benötigst du ein gültiges SSL-Zertifikat, welches beim Hoster einzurichten ist (davon gibt es auch kostenlose, Stichwort z.B.: Let's encrypt). Der Zugriff sowie die automatische Umleitung von http zu https ist beim Hoster einzurichten (dieser bietet bestimmt entsprechende Tutorials oder eine Hotline an).

    Falls du das nicht hinbekommen solltest, kannst du die Seite weiterhin über http://... betreiben. In diesem Fall musst du eben die Config anpassen, wie oben bereits erwähnt wurde. Die Config findest du in deinem CT-Verzeichnis unter: /sites/default/churchtools.config

    Du solltest dir aber auf jeden Fall Gedanken darüber machen, deine CT-Installation ausschliesslich nur noch über SSL zu betreiben, da ansonsten sämtlicher Datenverkehr zwischen Benutzer und CT unverschlüsselt übermittelt wird. Und bei CT handelt es sich durchaus um eine Applikation, die schützenswerte Daten bewirtschaftet...



  • @seetalchile Hallo,
    Ich bin jetzt etwas verwirrt. Ich soll über https://... zugreifen.
    Wie schon geschrieben funktioniert das nicht:
    "Seite kann nicht geöffnet werden, da Safari keine sichere Verbindung zum Server herstellen konnte"
    Ähnliche Meldung auch in anderen Browsern.
    SSL ist doch bei Strato eingerichtet. Siehe Bild oben

    Ich verstehe es nicht.... :-(



  • @Webmaster-EFM Dass der Zugriff über deine https://...-Adresse nicht funktioniert, habe ich gesehen. Da liegt wohl ein Problem in einem Hosting-Account bei strato vor. Das ist schwierig, von hier aus zu sagen... Ich empfehle dir, dich an den Support von strato zu wenden, damit sie deine Konfiguration überprüfen können. Sobald du über SSL zugreifen kannst, wird CT wieder korrekt funktionieren.

    Damit du und deine Leute aus der Gemeinde zwischenzeitlich trotzdem mit CT arbeiten können, empfehle ich dir, die Anpassung temporär in der Config vorzunehmen.



  • @Webmaster-EFM Euer Strato Zertifikat bezieht sich nur auf Eure Hauptadresse www.efm-mutterstadt.de bzw efm-mutterstadt.de, nicht aber auf churchtools.efm-mutterstadt.de. Daher gibt es die Fehlermeldung. Ihr müsstet also für die https Verbindung (die empfohlen wird) ein weiteres Zertifikat für churchtools.efm-mutterstadt.de bei Strato bestellen. Dann würde es keine Fehlermeldungen mehr geben.

    1. Lösung: Ihr bestellt ein weiteres kostenpflichtiges Zertifikat für churchtools.efm-mutterstadt.de. Wenn das eingerichtet ist und hier auch https erzwingen angehakt ist, läuft alles wie gewünscht. Das kostet wie gesagt etwas, ist aber die eigentlich richtige Lösung. Es könnte allerdings ggf. etwas dauern, bis die Lösung seitens Strato eingerichtet ist, sofern die Zertifikate nicht automatisch bereitgestellt werden.

    2. Lösung: Im Safari kannst Du in der Fehlermeldung auf Fortfahren klicken. Dann sollte die Seite trotzdem geladen werden. In anderen Browsern kann man ebenfalls bestätigen, dass man die Seite trotz fehlerhaften Zertifikats laden möchte. Hierzu wird allerdings jeder gezwungen, der mit churchtools arbeiten möchte. Daher ist hiervon eher abzuraten.

    3. Lösung: Im Verzeichnis sites/default/churchtools.config eine Zeile einfügen in der steht: https_only=false Dann kann die Churchtools Seite auch ohne https betrieben werden und alles funkioniert wieder. Das ist vermutlich für Euch die momentan schnellste und kostengünstigste Lösung. Langfristig empfehle ich aber das zweite Zertifikat. Wenn Ihr das dann habt, braucht ihr aus der churchtools.config nur die eingefügte Zeile wieder herauslöschen und alles läuft verschlüsselt über https.


  • ChurchTools Mitarbeiter

    Vielen Dank @sirdud, besser können wir es auch nicht beantworten.

    Nochmal zur Erklärung WARUM wir das gemacht haben: Der Server muß ja wissen, wer gerade am Rechner sitzt, dafür gibt es sogenannten Cookies, der die Anmeldung sozusagen zwischenspeichert. An diese Cookies kann man bestimmte Sicherheitsanforderung stellen. Wir haben nun hier die Sicherheit erhöht, das wurde uns von Beratern dringend empfohlen, um bestimme Angriffsmethoden ausschliessen zu können.
    Dadurch haben wir eben das Problem, dass ChurchTools ohne HTTPS (SSL) nicht mehr funktioniert. Um das aber weiterhin zu ermöglich haben wir die https_only Konfiguration ergänzt. So schaltet man sozusagen ChurchTools auf einen unsichereren Modus. Das ist nicht zu empfehlen für den Dauerbetrieb! Ohne SSL werden z.B. die Passwörter direkt über das Web übertragen. Wenn also jemand z.B. im WLAN mit dabei ist, kann er mit ein paar Tricks ohne Probleme mitlesen wie man sich in ChurchTools anmelden kann. Deshalb bitte dringend auf SSL wechseln.
    Unser Hosting-Angebot bietet selbstverständlich nur SSL Verbindung und zwar aktuelles Rating ist A. Das ist eins der höchsten Ratings die man erreichen kann.



  • @sirdud sagte in Dringend! Hilfe ! nach Update auf 3.17:

    https_only=false

    Hallo,
    danke für die Ausführlichen Kommentare.
    Ich finde in dem angegebenen Ordner nur eine Datei mit dem Namen: churchtools.example.config
    Dort habe ich https_only=true gefunden und auf false gesetzt. Allerdings ohne Erfolg.
    Das Anmelden funktioniert immer noch nicht :-(


  • admin

    @Webmaster-EFM hast du in dem Ordner in dem default liegt noch einen anderen Ordner? ZB intern, oder glaub bei euch churchtools.

    Hier findest du die richtige config. Versuch mal dort die Zeile einzutragen.



  • @MichaelG :
    sieht so aus:

    0_1483995719839_Ordner.GIF



  • @sirdud : So, habe bei Strato neues SSL bestellt und ist eingerichtet.
    trotzdem funktioniert es nicht.

    0_1483995770022_SSL-neu.GIF

    Ist da noch ein Fehler drin?



  • @Webmaster-EFM Eigentlich sieht das erst mal gut aus. Wenn man churchtools.efm-mutterstadt.de aufruft, wird man automatisch auf https://churchtools.efm-mutterstadt.de weitergeleitet. Damit sollte es ja eigentlich funktionieren.

    Was mich nur verwirrt ist, dass es anscheinend keine churchtools.config gibt. Ohne die funktioniert Churchtools nicht. Habt Ihr ggf. die Datei beim Update gelöscht? Bzw. wie wurde das Update gemacht?



  • Ich mache Update so:

    zip-File entpacken.
    auf dem Webserver den Ordner system im churchtools Verzeichnis umbenennen.
    den neuen system Ordner aus dem ausgepackten Archiv in das churchtools Verzeichnis kopieren.
    Webseite aufrufen -> DB Updates laufen automatisch



  • @sirdud : genau so mache ich es auch

    habe den Ordner mit der Config gefunden:

    0_1483996282623_Ordner2.GIF



  • Ok, dann hätte man dort die Änderung machen müssen. Da jetzt das Zertifikat aber installiert ist, sollte es eigentlich funktionieren.



  • Was kommt denn als Fehlermeldung? Oder wird einfach nur die Login Seite neu geladen?



  • @sirdud :die gleiche Meldung wie zuvor.
    Benutzername oder Passwort ist nicht korrekt.

    0_1483996718603_Anmeldung.GIF



  • Es liegt an dem Leerzeichen im Benutzernamen. Siehe Change Log:

    (CDB) In allen Usernamen wurden Leerzeichen und Sonderzeichen entfernt. Es führte sonst zu Problemen in LDAP-Wrapper Anbindung.

    Versuche mal WebmasterEFM als Benutzername.



  • @sirdud : Du bist mein Held :-)
    Jetzt geht es wieder !!!
    DANKE :-)



  • Super! :-) Gern geschehen!



  • @sirdud sagte in Dringend! Hilfe ! nach Update auf 3.17:

    (CDB) In allen Usernamen wurden Leerzeichen und Sonderzeichen entfernt. Es führte sonst zu Problemen in LDAP-Wrapper Anbindung.

    Die Art, wie das umgesetzt ist, finde ich schon etwas kurios. Bei mir wurde z.B. ein Leerzeichen entfernt, der Umlaut "ä" ist indes erhalten geblieben und wird anscheinend nicht als Sonderzeichen angesehen.


Anmelden zum Antworten
 

Es scheint als hättest du die Verbindung zu ChurchTools Forum verloren, bitte warte während wir versuchen sie wieder aufzubauen.