Fehlermeldung bei 3.17: Bearbeitung von Diensten



  • Hallo,

    gerade eben habe ich die Version 3.17 auf unserem Server installiert. Dann habe ich mich angemeldet, den Cron Job manuell gestartet und anschließend versucht, einen Dienst am kommenden Sonntag zu bearbeiten. Dabei kommt es zu folgender Fehlermeldung:


    Beschreibung: [200] parsererror Fehler: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

    Warning: array_filter() expects at most 2 parameters, 3 given in /kunden/148576_47506/rp-hosting/75/82/webseiten/churchtools/system/churchservice/serviceexchange/cs_serviceExchangeService.php on line 107

    Warning: array_filter() expects at most 2 parameters, 3 given in /kunden/148576_47506/rp-hosting/75/82/webseiten/churchtools/system/churchservice/serviceexchange/cs_serviceExchangeService.php on line 107

    Warning: Cannot modify header information - headers already sent by (output started at /kunden/148576_47506/rp-hosting/75/82/webseiten/churchtools/system/churchservice/serviceexchange/cs_serviceExchangeService.php:107) in /kunden/148576_47506/rp-hosting/75/82/webseiten/churchtools/system/includes/functions.php on line 429
    {"status":"success","data":[{"personId":"24","personName":"xxx","eventServiceId":"344","calTitle":"Gottesdienst","eventDate":"22.01.2017 10:00","serviceExchangeId":null,"serviceExchangeStatus":null},{"personId":"23","personName":"yyy","eventServiceId":"345","calTitle":"Gottesdienst","eventDate":"29.01.2017 10:00","serviceExchangeId":null,"serviceExchangeStatus":null}]}


    Viele Grüße
    Bernd


  • ChurchTools Mitarbeiter

    Das Problem tritt auf wenn man eine alte PHP Version hat. Ab PHP Version 5.6 funktioniert das. Wir kümmern uns darum, dass es auch noch bis zur aktuell unterstützten Version 5.3.9 funktioniert.

    Generell ist es aber ratsam auf eine aktuelle Version upzudaten. Am besten >= 7

    Alles unter 5.6 wird von PHP nicht mehr unterstützt und hat Sicherheitslücken.



  • Hallo David,

    danke für die schnelle Hilfe! Ich habe jetzt die PHP Version 5.6 eingestellt. Damit kommt der Fehler nicht mehr.

    Viele Grüße
    Bernd



  • @davidschilling Kannst du bt. kurz informieren, ab wann die "alten" PHPler (wir haben noch 5.4.45) auf CT 3.17 upgraden können.



  • @hja Möglicherweise ist es sinnvoll, für eine neuere PHP-Version auf Eurem Server zu sorgen? Ansonsten könnte Ihr ab der nächsten Version nicht mehr updaten: http://forum.churchtools.de/topic/3223/minimal-unterstützte-php-version

    Auf unserem Server kann ich mehrere PHP-Versionen nebeneinander nutzen. Da wir noch mit eine alten TYPO3 Version arbeiten, die nichts neueres als PHP5.2 verträgt, habe ich bis zur Fertigstellung der neuen Homepage die PHP Version für churchtools per .htaccess entsprechend auf mittlerweile 7.0 gesetzt. Vielleicht ist das ja bei Euch auch möglich.



  • @sirdud danke für den Tipp. Ich frage mal bei unserem Hoster an.


Anmelden zum Antworten
 

Es scheint als hättest du die Verbindung zu ChurchTools Forum verloren, bitte warte während wir versuchen sie wieder aufzubauen.